No gateway or traffic reachability with Nexus FEX and Nexus 9000

If you have deployed a FEX with a Cisco Nexus 9K switch, either the 23XX or an integrated FEX within a chassis, and you’re unable to reach the gateway and/or having general traffic issues, you need to look at your FEX configuration on your Cisco Nexus 9000 series switch. For those who’re familiar with deploying FEX with Cisco Nexus 5000 series switches it can be possible to get the configuration incorrect if you follow the method of deploying a FEX as you’ve always done. Here below is the basic configuration for getting a FEX up and running:

###Choose your interfaces you'll connect to your FEX with
interface eth1/A-B
channel-group 100
no shutdown
exit

###Now you need to create and configure your port-channel, in this case 100, with FEX 100
interface port-channel 100
switchport
switchport mode fex-fabric
fex associate 100
no shutdown
exit


If you have an issue with your FEX operating strangely, look at the configuration of your port-channel and physical interfaces associated to the FEX port-channel. If you have the following:

interface port-channel 100
switchport
switchport mode fex-fabric
lacp suspend-individual ### REMOVE THIS LINE!
fex associate 100
no shutdown


On the Cisco Nexus 9000 platform the FEX port-channel is NOT an LACP port-channel. This shouldn't be an "allowed" configuration option; however, if you're used to parenting a FEX with a Cisco Nexus 5000 series device, this is an honest mistake to make, but an easy one to fix! Here is the link to the Cisco documentation: Cisco Nexus 2000 NX OS configuration guide for Cisco Nexus 9000 7.X